Die Version der SDK-Plattformtools ((23)) ist zu alt, um APIs zu überprüfen, die mit API 23 kompiliert wurden

Lesezeit: 2 Minuten

Ich erhalte diesen seltsamen Fehler in der ersten Zeile jeder Datei in meinem Android Studio. Alles war in Ordnung, bis ich mein Android Studio aktualisiert habe. Könnte mir jemand erklären, was los ist und wie man solche Fehler loswird? Ich würde mich über jede Hilfe dabei freuen.

PS: Trotz dieses Fehlers kann ich meinen Code erfolgreich kompilieren und ausführen.

  • @Alok das ist anders. „Die SDK-Plattform-Tools-Version ((22)) ist zu alt, um mit API 23 kompilierte APIs zu überprüfen“ klingt logischer als „Die SDK-Plattform-Tools-Version ((23)) ist zu alt, um mit API 23 kompilierte APIs zu überprüfen.“ .

    – RuslanSch

    18. Oktober 2015 um 8:44 Uhr

  • Wenn der Fehler „Die SDK-Plattform-Tools-Version ((20)) ist zu alt, um mit API 22 kompilierte APIs zu überprüfen“ lautete, was sollte ich dann tun, wenn ich mein SDK nicht aktualisieren möchte? @ Freeze

    – Gumuruh

    18. April 2016 um 3:57 Uhr

Aktualisieren Sie Ihre Android-SDK-Plattformtools vom SDK-Manager auf die Revision 23.0.1. Klicken Sie in Android Studio auf Datei -> Caches ungültig machen/Neustart…

Das ist es. Der Fehler muss jetzt weg sein.

  • @MichaelKessler wie hast du es letztendlich gelöst?

    Benutzer4414636

    22. November 2015 um 15:05 Uhr

  • @stack, ich hatte keine Zeit und habe das gesamte Projekt-SDK auf 21 geändert … Werde versuchen, es später herauszufinden.

    – Michael Keßler

    22. November 2015 um 23:28 Uhr

  • Das Aktualisieren meiner Plattform-Tools hat bei mir funktioniert (ich musste keine Caches ungültig machen). Gehen Sie zum Aktualisieren zu Android Studio -> Nach Updates suchen (Mac). Beachten Sie, dass die Aktualisierung von Android Studio selbst durchgeführt wurde nicht repariere es. Es war speziell die Aktualisierung von Plattform-Tools.

    – tytk

    15. Juni 2016 um 1:16 Uhr

Benutzer-Avatar
Kavitha

Wie der Fehler sagt, müssen die Plattform-Tools auf einer neueren Version sein. Aktualisieren,

  1. Offen SDK manager
  2. Klicken Sie unten im Dialogfeld auf den Link Launch Standalone SDK Manager -> Stand ist der 23.01
  3. Installieren Sie das aktualisierte Paket
  4. Cache ungültig machen als File -> Invalidate caches/Restart"

Ich konnte das Problem unter Windows wie folgt lösen:

Gehen Sie zu Tools -> Android -> SDK Manager -> klicken Sie auf Update the android Android SDK platform tools to the Latest. Sobald die Aktualisierung abgeschlossen ist, sollte der Fehler verschwunden sein.

Das hat bei mir funktioniert, ich hoffe, es funktioniert auch bei dir. Prost

  • Wie unterscheidet sich das von den anderen Antworten?

    – OneCricketeer

    14. Dezember 2017 um 14:53 Uhr

Zuerst sollten Sie Ihr SDK aktualisieren, für das Update gehen Sie zum SDK Manager und klicken Sie auf Pakete installieren. Wenn diese Schaltfläche nicht aktiv ist, klicken Sie auf Extras->Optionen->Cache leeren und schließen Sie dann den SDK-Manager und öffnen Sie ihn erneut. Jetzt ist Ihre Schaltfläche aktiv. Gehen Sie nach dem Update des SDK Managers zu Android Studio und klicken Sie auf Datei->Cache ungültig machen/Neustart->Cache ungültig machen/Neustart. jetzt ist dein problem gelöst. Viel Spaß!

Ich hatte den gleichen Fehler, ich löste ihn so, dass ich Alt + Enter drücke und Inspektion deaktivieren wähle, der Fehler wird entfernt, ich hoffe, das wird auch für Sie funktionieren.Geben Sie hier die Bildbeschreibung ein

1215370cookie-checkDie Version der SDK-Plattformtools ((23)) ist zu alt, um APIs zu überprüfen, die mit API 23 kompiliert wurden

This website is using cookies to improve the user-friendliness. You agree by using the website further.

Privacy policy