Anforderungen konnten nicht in einen installierbaren Satz von Paketen aufgelöst werden

Lesezeit: 9 Minuten

Ich habe versucht, das jasonlewis/enhanced-router-Paket im Laravel-Starter-Kit zu installieren, und wenn ich das Composer-Update ausführe, wird es nicht installiert und gibt einige Fehler. Anfangs dachte ich, das Problem läge in der Composer-Zeile für jasonlewis/enhanced-router ("jasonlewis/enhanced-router": "dev-master"), aber ich habe es entfernt und habe den gleichen Fehler.

Ich habe versucht, nach ähnlichen Problemen zu suchen, kann aber nicht herausfinden, was das Abhängigkeitsproblem ist, das ich bekomme.

Unten ist das Ergebnis, das ich nach dem Laufen bekomme composer update:

Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: remove laravel/framework 4.0.x-dev
    - Conclusion: don't install laravel/framework 4.0.x-dev
    - Conclusion: don't install laravel/framework v4.0.10
    - Conclusion: don't install laravel/framework v4.0.9
    - Conclusion: don't install laravel/framework v4.0.8
    - Conclusion: don't install laravel/framework v4.0.7
    - Conclusion: don't install laravel/framework v4.0.6
    - Conclusion: don't install laravel/framework v4.0.5
    - Conclusion: don't install laravel/framework v4.0.4
    - Conclusion: don't install laravel/framework v4.0.3
    - Conclusion: don't install laravel/framework v4.0.2
    - Conclusion: don't install laravel/framework v4.0.1
    - Conclusion: don't install laravel/framework v4.0.0
    - Conclusion: don't install laravel/framework v4.0.0-BETA4
    - Installation request for zizaco/confide dev-master -> satisfiable by zizaco/confide[dev-master].
    - Conclusion: don't install laravel/framework v4.0.0-BETA3
    - bllim/datatables dev-master requires illuminate/filesystem >=4.0.0 -> satisfiable by laravel/framework[4.0.x-dev,
4.1.x-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, v4.0.
9, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9], illuminat
e/filesystem[4.0.x-dev, 4.1.x-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.
6, v4.0.7, v4.0.8, v4.0.9, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4
.1.8, v4.1.9].
    - bllim/datatables 1.3.0 requires illuminate/filesystem >=4.0.0 -> satisfiable by laravel/framework[4.0.x-dev, 4.1.x
-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, v4.0.9, v4
.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9], illuminate/fil
esystem[4.0.x-dev, 4.1.x-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4
.0.7, v4.0.8, v4.0.9, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8,
 v4.1.9].
    - bllim/datatables dev-master requires illuminate/filesystem >=4.0.0 -> satisfiable by laravel/framework[4.0.x-dev,
4.1.x-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, v4.0.
9, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9], illuminat
e/filesystem[4.0.x-dev, 4.1.x-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.
6, v4.0.7, v4.0.8, v4.0.9, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4
.1.8, v4.1.9].
    - bllim/datatables v1.3.1 requires illuminate/filesystem >=4.0.0 -> satisfiable by laravel/framework[4.0.x-dev, 4.1.
x-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, v4.0.9, v
4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9], illuminate/fi
lesystem[4.0.x-dev, 4.1.x-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v
4.0.7, v4.0.8, v4.0.9, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8
, v4.1.9].
    - bllim/datatables v1.3.2 requires illuminate/filesystem >=4.0.0 -> satisfiable by laravel/framework[4.0.x-dev, 4.1.
x-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, v4.0.9, v
4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9], illuminate/fi
lesystem[4.0.x-dev, 4.1.x-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v
4.0.7, v4.0.8, v4.0.9, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8
, v4.1.9].
    - bllim/datatables v1.3.3 requires illuminate/filesystem >=4.0.0 -> satisfiable by laravel/framework[4.0.x-dev, 4.1.
x-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, v4.0.9, v
4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9], illuminate/fi
lesystem[4.0.x-dev, 4.1.x-dev, dev-master, 4.2.x-dev, v4.0.0, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v
4.0.7, v4.0.8, v4.0.9, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8
, v4.1.9].
    - Can only install one of: laravel/framework[v4.0.0-BETA2, 4.1.x-dev].
    - Can only install one of: laravel/framework[v4.0.0-BETA2, dev-master].
    - Can only install one of: laravel/framework[v4.0.0-BETA2, 4.2.x-dev].
    - Can only install one of: laravel/framework[v4.1.0, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.1, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.10, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.11, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.12, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.2, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.3, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.4, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.5, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.6, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.7, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.8, v4.0.0-BETA2].
    - Can only install one of: laravel/framework[v4.1.9, v4.0.0-BETA2].
    - don't install illuminate/filesystem 4.0.x-dev|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.0.0|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.0.1|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.0.10|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.0.2|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.0.3|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.0.4|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.0.5|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.0.6|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.0.7|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.0.8|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.0.9|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem 4.1.x-dev|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem 4.2.x-dev|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.0|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.1|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.10|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.11|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.12|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.2|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.3|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.4|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.5|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.6|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.7|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.8|don't install laravel/framework v4.0.0-BETA2
    - don't install illuminate/filesystem v4.1.9|don't install laravel/framework v4.0.0-BETA2
        - don't install illuminate/filesystem dev-master|don't install laravel/framework v4.0.0-BETA2
        - Installation request for laravel/framework 4.0.* -> satisfiable by laravel/framework[4.0.x-dev, v4.0.0, v4.0.0-BET
    A2, v4.0.0-BETA3, v4.0.0-BETA4, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, v4.0.9].
        - Installation request for bllim/datatables * -> satisfiable by bllim/datatables[1.3.0, dev-master, v1.3.1, v1.3.2,
    v1.3.3].

Und meine composer.json

{
    "name": "andrew13/Laravel-4-Bootstrap-Starter-Site",
    "description": "Laravel 4 Starter Site",
    "keywords": ["laravel","Starter Site"],
    "license": "MIT",
    "authors": [
        {
            "name": "Andrew Elkins",
            "homepage": "http://www.andrewelkins.com"
        }
    ],
    "require": {
        "laravel/framework": "4.0.*",
        "twbs/bootstrap":  "3.0.0",
        "zizaco/confide": "dev-master",
        "zizaco/entrust": "dev-master",
        "jasonlewis/basset": "dev-master",
        "robclancy/presenter": "1.2.*",
        "j20/php-uuid": "dev-master",
        "bllim/datatables": "*",
        "blueimp/jquery-file-upload": "dev-master",
        "jasonlewis/enhanced-router": "dev-master"
    },
    "require-dev": {
        "way/generators": "dev-master",
        "mockery/mockery": "[email protected]",
        "summerstreet/woodling": "0.1.*",
        "barryvdh/laravel-ide-helper": "dev-master",
        "leafo/lessphp": "v0.4.0",
        "natxet/CssMin": "dev-master",
        "lmammino/jsmin4assetic": "1.0.*"
    },
    "autoload": {
        "classmap": [

            "app/commands",
            "app/controllers",
            "app/library",
            "app/models",
            "app/presenters",
            "app/database/migrations",
            "app/database/seeds",
            "app/tests/library"
        ]
    },
    "scripts": {
        "pre-update-cmd": [
            "php artisan clear-compiled"
        ],
        "post-install-cmd": [
            "php artisan optimize"
        ],
        "post-update-cmd": [
            "php artisan optimize"
        ]
    },
    "config": {
        "preferred-install": "dist"
    },
    "minimum-stability": "dev"
}

Ich habe nicht mit dem grundlegenden Laravel-Paket begonnen, das ich verwendet habe andrew13/Laravel-4-Bootstrap-Starter-Site

Willkommen beim schlechtesten Feature von Composer!

Das Problem ist also, dass Sie Konflikte in Ihren Abhängigkeiten haben, die schwer zu erkennen sind.

Sie haben eine Anforderung für "laravel/framework": "4.0.*", in Ihrer composer.json. Sie haben auch eine Anforderung für "zizaco/confide": "dev-master"

Wenn wir in der composer.json nach „zizaco/confide“ in github suchen, sehen wir:

“beleuchten/unterstützen”: “4.1.x”,

Die Composer-Funktion, die Ihnen ein Problem bereitet, ist, dass die replace Stichwort TÄTIGT WELTWEIT GESAMT PACKAGIST.

Also weil die Das Paket „illuminate/support“ wird durch Laravel selbst ersetzt Wenn Composer versucht, die Anforderung von “illuminate/support”: “4.1.x” zu erfüllen, versucht er tatsächlich, stattdessen Laravel Version 4.1.x herunterzuladen.

Das kollidiert mit Ihrer Anforderung von Laravel Version 4.0. * und daher können die Abhängigkeiten nicht aufgelöst werden.

Ich denke, es kann keine triviale Lösung für Ihr Problem geben.

Ich wollte vorschlagen, eine frühere Version von zizaco/confide anstelle von dev-master anzugeben, die von illuminate/support Version 4.0.x statt 4.1.x abhängig ist – dies würde jedoch bedeuten, von zizaco/confide 3.x auf 2 zu wechseln .x, was wahrscheinlich nicht akzeptabel ist.

Die einzige andere Möglichkeit wäre, Ihre Anforderung von Laravel 4.0.x auf 4.1.* zu ändern – was akzeptabel sein kann oder nicht, je nachdem, wie viel Arbeit Ihnen das verursachen würde.

  • Er kann es forken und den Komponisten ändern, nicht wahr?

    – Aysennoussi

    23. Mai 2014 um 10:12 Uhr

  • Er könnte, aber aus verschiedenen Gründen ist es in Composer wirklich ärgerlich, Code zu forken, nur um kleine Änderungen vorzunehmen.

    – Danack

    23. Mai 2014 um 11:31 Uhr

  • Übrigens, wenn hier jemand mit nicht übereinstimmenden Anforderungen ankommt, gehen die Sonstiges Weg – das Paket, das Sie installieren möchten, erfordert eine Abhängigkeit, die ist älter als eine bereits installierte – Sie können einfach manuell composer require das ältere Paket. Installieren Sie dann das gewünschte Paket, und die Anforderungen werden erfüllt. Dazu hängen Sie die ältere Version an die require-Anweisung an. Z.B, composer require symfony/event-dispatcher ~2.2.

    – Tyler Hayes

    9. Januar 2016 um 2:02 Uhr


  • Danke @TylerHayes! Dein Kommentar war wirklich hilfreich!

    – cgaldiolo

    11. April 2016 um 21:48 Uhr

  • Ich bin neu bei Composer und hoffe, dass ich das nach ein paar Jahren klären kann: Warum Würde es versuchen, Ihre Versionsanforderungen selbst zu ändern und Laravel 4.1.x zu installieren? Ist das ein Tippfehler? Ich habe das gleiche Problem und mache mir langsam Sorgen, dass es keine Lösung gibt.

    – Brandon

    8. Dezember 2016 um 14:52 Uhr


1246950cookie-checkAnforderungen konnten nicht in einen installierbaren Satz von Paketen aufgelöst werden

This website is using cookies to improve the user-friendliness. You agree by using the website further.

Privacy policy