Fehler „Root composer.json erfordert PHP ^7.3, aber Ihre PHP-Version (8.0.0) erfüllt diese Anforderung nicht.“ [duplicate]

Lesezeit: 3 Minuten

Benutzer-Avatar
NIKHIL NEDIYODATH

Ich habe einen ungewöhnlichen Fehler beim Ausführen von composer install Befehl.

Es erfordert PHP 7.3, während ich PHP 8.0.0 habe. Diese Frage unterscheidet sich von Überschreiben Sie die PHP-Basisabhängigkeit in Composer, weil ich eine höhere PHP-Version (8.0.0) habe als erforderlich. Warum funktioniert es nicht?

Problem 1
    - Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement.         Problem 2
    - asm89/stack-cors is locked to version v2.0.1 and an update of this package was not requested.
    - asm89/stack-cors v2.0.1 requires php ^7.0 -> your php version (8.0.0) does not satisfy that requirement.   Problem 3
    - laravel/framework is locked to version v8.10.0 and an update of this package was not requested.
    - laravel/framework v8.10.0 requires php ^7.3 -> your php version (8.0.0) does not satisfy that requirement.   Problem 4
    - laravel/tinker is locked to version v2.4.2 and an update of this package was not requested.
    - laravel/tinker v2.4.2 requires php ^7.2 -> your php version (8.0.0) does not satisfy that requirement.   Problem 5
    - facade/flare-client-php is locked to version 1.3.6 and an update of this package was not requested.
    - facade/flare-client-php 1.3.6 requires php ^7.1 -> your php version (8.0.0) does not satisfy that requirement.   Problem 6
    - facade/ignition is locked to version 2.4.1 and an update of this package was not requested.
    - facade/ignition 2.4.1 requires php ^7.2.5 -> your php version (8.0.0) does not satisfy that requirement.   Problem 7
    - fzaninotto/faker is locked to version v1.9.1 and an update of this package was not requested.
    - fzaninotto/faker v1.9.1 requires php ^5.3.3 || ^7.0 -> your php version (8.0.0) does not satisfy that requirement.   Problem 8
    - nunomaduro/collision is locked to version v5.0.2 and an update of this package was not requested.
    - nunomaduro/collision v5.0.2 requires php ^7.3 -> your php version (8.0.0) does not satisfy that requirement.   Problem 9
    - asm89/stack-cors v2.0.1 requires php ^7.0 -> your php version (8.0.0) does not satisfy that requirement.
    - fruitcake/laravel-cors v2.0.2 requires asm89/stack-cors ^2.0.1 -> satisfiable by asm89/stack-cors[v2.0.1].
    - fruitcake/laravel-cors is locked to version v2.0.2 and an update of this package was not requested.

Aus den Kommentaren geht hervor, dass der folgende Befehl in gewissem Umfang funktioniert. Es funktioniert auch für meinen Fall

composer install --ignore-platform-reqs

  • stackoverflow.com/questions/32838881/… Meine Frage unterscheidet sich davon, weil ich eine höhere Version als erforderlich habe.

    – NIKHIL NEDIYODATH

    26. Dezember 2020 um 9:08 Uhr

  • Ja, aber Sie können auch Plattformen simulieren, wie in der Antwort dort erwähnt.

    – nice_dev

    26. Dezember 2020 um 9:15 Uhr

  • Es hängt davon ab, ob. Arbeitest du über Docker? Dies bedeutet, dass Ihr Container über die erforderliche PHP-Version verfügt. und wenn Sie es außerhalb Ihres Updates versuchen und Ihre PHP-Version Ihres Betriebssystems höher ist, erhalten Sie diese Warnung. Eine Möglichkeit, dies zu lösen, besteht darin, Composer Update mit dem Flag –ignore-platform-reqs auszuführen.

    – Maik Lowrey

    10. Februar 2021 um 9:48 Uhr

  • ‘composer install –ignore-platform-reqs’ können Sie auch verwenden. Es könnte in Ihrem Fall funktionieren.

    – Yagnesh bhalala

    28. August 2021 um 18:25 Uhr


  • Weiterlesen über Beschränkungen der Schreibversion.

    – Pathos

    7. März um 22:20 Uhr

Benutzer-Avatar
VirCom

Es liegt daran, dass in Ihrem Projekt in composer.json Datei hast du:

"require": {
    "php": ">=7.3",
    .....
},

Versuchen Sie, diese Anforderung wie folgt zu aktualisieren:

"require": {
    "php": "^7.3|^8.0",
    .....
},

  • Anstelle des Einzelrohrs sollte das Doppelrohr verwendet werden. Die Single funktioniert noch, aber nur für die Nachwelt: github.com/composer/composer/issues/6755

    – Gottkampf

    21. Januar 2021 um 16:19 Uhr

  • Dies ist keine geeignete Lösung für dieses Problem. Es funktioniert nicht. Sie können den Code von hier aus sehen prnt.sc/yoo7gw und der Fehler hier prnt.sc/yoo802

    – Md Rasheduzzaman

    8. Februar 2021 um 4:49 Uhr

  • Ich stimme nicht zu … Sie haben: gabrielbull/ups-api 0.8.0 erfordert PHP ^5.5 || ^7.0 -> Ihre PHP-Version (8.0.1) erfüllt diese Anforderung nicht. Sie müssen also den PHP-Interpreter Version 5.5 oder 7.0 und höher verwenden. Aber Sie haben 8.0.1. Also müssen Sie zuerst das Paket gabrielbull/ups-api auf Version 1.2.0 oder höher aktualisieren

    – VirCom

    10. Februar 2021 um 6:29 Uhr

  • composer install --ignore-platform-reqs

    – Bira

    21. April 2021 um 1:40 Uhr

  • Mehr zur Versionssyntax: getcomposer.org/doc/articles/…

    – Pathos

    7. März um 22:18 Uhr

1354510cookie-checkFehler „Root composer.json erfordert PHP ^7.3, aber Ihre PHP-Version (8.0.0) erfüllt diese Anforderung nicht.“ [duplicate]

This website is using cookies to improve the user-friendliness. You agree by using the website further.

Privacy policy