anaconda/conda – installiert eine bestimmte Paketversion

Lesezeit: 3 Minuten

Ich möchte das Paket ‚rope‘ in meiner aktuellen aktiven Umgebung mit conda installieren. Derzeit sind die folgenden ‘Rope’-Versionen verfügbar:

(data_downloader)[email protected] ~/code/data_downloader $ conda search rope
Using Anaconda Cloud api site https://api.anaconda.org
Fetching package metadata: ....
cached-property              1.2.0                    py27_0  defaults        
                             1.2.0                    py34_0  defaults        
                             1.2.0                    py35_0  defaults        
                             1.3.0                    py27_0  defaults        
                             1.3.0                    py34_0  defaults        
                             1.3.0                    py35_0  defaults        
rope                         0.9.4                    py26_0  defaults        
                             0.9.4                    py27_0  defaults        
                             0.9.4                    py33_0  defaults        
                             0.9.4                    py34_0  defaults        
                             0.9.4                    py26_1  defaults        
                             0.9.4                    py27_1  defaults        
                             0.9.4                    py33_1  defaults        
                             0.9.4                    py34_1  defaults        
                          .  0.9.4                    py35_1  defaults        

Ich möchte folgendes installieren:

                         1.3.0                    py35_0  defaults        

Ich habe alle möglichen Permutationen von „conda install“ ausprobiert, die ich hier nicht auflisten werde, da keine davon richtig ist.

Ich bin mir auch nicht sicher, was die py35_0 ist (ich nehme an, dies ist die Version von Python, für die das Paket erstellt wurde?) und ich weiß auch nicht, was “Standardwerte” bedeutet?

  • Hast du versucht conda install package=version? z.B conda install matplotlib=1.4.3

    – Charly Parker

    7. November 2020 um 16:19 Uhr


  • @CharlieParker – Danke, das hat funktioniert. Ich konnte nicht feststellen, dass die Verwendung von equals auf diese Weise aus dem Lesen des Hilfetexts funktionieren würde. — Der Hilfetext ließ es wirklich so aussehen, als müsste ich die Revisionsnummer irgendwie mit einer Versionsnummer korrelieren und sie so angeben (mit --revision). Danke noch einmal!

    – BrainSlugs83

    31. Januar 2021 um 3:20 Uhr


  • Wenn Sie zumindest eine bestimmte Version wünschen, vergessen Sie die Anführungszeichen nicht conda install -y networkx">=2.5"

    – Charly Parker

    19. Juli 2021 um 16:35 Uhr

Benutzeravatar von Chris
Chris

So installieren Sie ein bestimmtes Paket:

conda install <pkg>=<version>

z.B:

conda install matplotlib=1.4.3

Für komplexere Ausdrücke kann die Beziehung zitiert werden:

conda install 'matplotlib>=1.4.3'

# or

conda install "matplotlib>=1.4.3"

  • Gibt es eine Möglichkeit zu sagen “mindestens Version 2.5”? z.B conda install -y networkx=>2.5?

    – Charly Parker

    19. Juli 2021 um 16:29 Uhr

  • das hat bei mir funktioniert: conda install -y networkx">=2.5"

    – Charly Parker

    19. Juli 2021 um 16:34 Uhr

  • das hat bei mir nicht funktioniert: conda install samtools>=1.14

    – Ömer An

    10. November 2021 um 2:38 Uhr

  • @ÖmerAn man muss Shell daran hindern die auszuwerten > Symbol: conda install 'samtools>=1.14'

    – merv

    14. Dezember 2021 um 22:59 Uhr


Es gibt keine Fassung 1.3.0 zum rope. 1.3.0 bezieht sich auf das Paket cached-property. Die höchste verfügbare Version von rope ist 0.9.4.

Sie können verschiedene Versionen mit installieren conda install package=version. Aber in diesem Fall gibt es nur eine Version von rope also brauchst du das nicht.

Der Grund, warum Sie die sehen cached-property in dieser Auflistung ist, weil es die Zeichenfolge enthält "rope": “cached-p Seil erty”

py35_0 bedeutet, dass Sie eine Python-Version benötigen 3.5 für diese spezielle Version. Wenn Sie nur haben python3.4 und das Paket ist nur für die Version 3.5 Sie können es nicht mit Conda installieren.

Bei der bin ich mir nicht ganz sicher defaults entweder. Es sollte ein Hinweis darauf sein, dass sich dieses Paket im Standard-Conda-Kanal befindet.

  • Danke – ja, ich fange mit Conda an und habe total übersehen, dass “cached-property” nur ein weiteres Paket ist.

    – s5s

    16. Juli 2016 um 14:47 Uhr

  • @s5s Die defaults gibt an, dass das Paket aus dem Standard-Paket-Repository installiert wird. Das pyXY zeigt an, dass dieses bestimmte Paket für Python XY verfügbar ist, während die _Z gibt die “Build-Nummer” an, die erhöht wird, wenn die Art und Weise, wie das Paket erstellt wird, geändert wird, aber der eigentliche Code im Paket unverändert bleibt.

    – darthbith

    21. Juli 2016 um 16:53 Uhr

  • Befehl zum Installieren eines bestimmten Pakets conda install rope=0.9.4 Dies ist ein Link zur Conda-Dokumentation

    – Orthogod

    26. März 2019 um 13:50 Uhr


  • Wie kann ich die Python-Version auswählen? Wenn ich mit der Version 1.3.0 des Pakets für Python 3.5 installieren möchte?

    – Soonmyun Jang

    5. Oktober 2020 um 9:29 Uhr

  • für Leute, die nach einer tatsächlichen Antwort mit ausführbarem Code suchen: conda install <pkg>=<version> z.B conda install matplotlib=1.4.3

    – Charly Parker

    4. Januar 2021 um 21:41 Uhr

Benutzeravatar von Jonathan L
Jonatan L

Wenn eines dieser Zeichen, ‘>’, ‘<', '|' oder '*' verwendet werden, muss ein einfaches oder doppeltes Anführungszeichen verwendet werden

conda install [-y] package">=version"
conda install [-y] package'>=low_version, <=high_version'
conda install [-y] "package>=low_version, <high_version"

conda install -y torchvision">=0.3.0"
conda install  openpyxl'>=2.4.10,<=2.6.0'
conda install "openpyxl>=2.4.10,<3.0.0"

wo Option -y, –yes Fragt nicht nach Bestätigung.

Hier ist eine Zusammenfassung:

Format         Sample Specification     Results
Exact          qtconsole==4.5.1         4.5.1
Fuzzy          qtconsole=4.5            4.5.0, 4.5.1, ..., etc.
>=, >, <, <=  "qtconsole>=4.5"          4.5.0 or higher
               qtconsole"<4.6"          less than 4.6.0

OR            "qtconsole=4.5.1|4.5.2"   4.5.1, 4.5.2
AND           "qtconsole>=4.3.1,<4.6"   4.3.1 or higher but less than 4.6.0

Trank der oben genannten Informationen Kredit an Conda-Spickzettel

Getestet auf conda 4.7.12

  • Die Anführungszeichen scheinen nicht obligatorisch zu sein anaconda-project.yml.

    – Skippy le Grand Gourou

    19. Februar 2021 um 20:02 Uhr

  • Nun, das macht in einer Konsole absolut Sinn (und das gleiche gilt für pip) : ohne Anführungszeichen werden die Kleiner/Größer-als-Zeichen als Umleitungen interpretiert.

    – Skippy le Grand Gourou

    23. Februar 2021 um 14:27 Uhr

  • Dies ist die beste Antwort, da sie am vollständigsten ist und eine direkte Antwort auf die Frage liefert. Das bekommt meine Up-Vote!!

    – Rich Lysakowski PhD

    30. März 2021 um 20:46 Uhr

  • Warum werden die Anführungszeichen benötigt?

    – Charly Parker

    19. Juli 2021 um 16:30 Uhr

  • @CharlieParker, die Anführungszeichen bilden Zeichen wie ‘>’, ‘<', '|' oder '*' richtig interpretiert werden

    – Jonathan L

    21. Juli 2021 um 23:49 Uhr

1430300cookie-checkanaconda/conda – installiert eine bestimmte Paketversion

This website is using cookies to improve the user-friendliness. You agree by using the website further.

Privacy policy